Website Maintenance

Incident Report for JJCS Service Status Portal

Resolved

Our website and App are now full back up and running. If you experience any issues or problems with any of our services please contact the Helpdesk at: Helpdesk@JJCleaningServices.uk .

Thank you for your patience and cooperation.
Posted Aug 02, 2025 - 21:34 UTC

Investigating

The JJ Cleaning Services website and app are currently down for maintenance. Areas of the website and app will still be operational but with limited operations.

We aim to get all updates done by Saturday 2nd August at 12:00PM
Posted Aug 02, 2025 - 15:22 UTC
This incident affected: JJ Cleaning Services Website and JJCS App.