Account Management and invoicing

Incident Report for JJCS Service Status Portal

Resolved

This incident has been resolved. We appreciate your patience.

If you experience any issues with your account or our services and systems please reach through our helpdesk at: Support@JJCleaningServices.freshdesk.com

Kind Regards,

JJ Cleaning Services
IT Helpdesk Team
Posted Aug 17, 2025 - 15:38 UTC

Investigating

We are currently experiencing a IT outage on our account management and invoicing system.

We have reported this issue to the system provider but we don’t have an expected resolution time or date at the moment. We apologise for any inconvenience this may have caused you.

You can check the status of our systems 24/7 at: www.JJCleaningServices.uk/service-status

If you experience any issues with your account please reach out at: Support@JJCleaningServices.freshdesk.com

Kind Regards,

JJ Cleaning Services
IT Support Team
Posted Aug 17, 2025 - 12:23 UTC
This incident affected: Accounts & Finance Systeam and JJCS App.