Nationwide Systems Outage

Incident Report for JJCS Service Status Portal

Resolved

This incident has been resolved.

If you experience any issues with your account please reach out at: Support@JJCleaningServices.freshdesk.com

Kind Regards,

JJ Cleaning Services
IT Support Team
Posted Oct 21, 2025 - 07:37 UTC

Identified

We have identified the cause of the problem and are currently implementing fixes. We expect to have the outage resolved by the early hours of the morning. Thank you for your patience and understanding.

You can check the status of our systems 24/7 at: www.JJCleaningServices.uk/service-status

If you experience any issues with your account please reach out at: Support@JJCleaningServices.freshdesk.com

Kind Regards,

JJ Cleaning Services
IT Support Team
Posted Oct 20, 2025 - 19:45 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 11:06 UTC

Investigating

All our systems are currently experiencing partial outages. This is something that is affecting a large number of other organisations nationwide wide.

We are unfortunately unable to provide any information or updates on the situation or the estimated time to fit the issue and to have all our systems back up and running.

You can check the status of our systems 24/7 at: www.JJCleaningServices.uk/service-status

If you experience any issues with your account please reach out at: Support@JJCleaningServices.freshdesk.com

Kind Regards,

JJ Cleaning Services
IT Support Team
Posted Oct 20, 2025 - 11:05 UTC
This incident affected: JJ Cleaning Services Website, Accounts & Finance Systeam, and JJCS App.